How to pack your Blender file for uploading

How to pack your Blender file for uploading

You can upload your files to RenderStreet either packed or unpacked. Read below for instructions applicable to each case. These instructions only apply if you wish to upload the project manually, via FTP, cloud transfer or directly to our website. If you use our Blender plug-in, these actions are not necessary, as the plugin collects all project assets and upload them to our servers.


Important!! All external files that are uploaded along with the blend file (whether the project has been packed or not) must be referred with relative paths in the blend file for them to work correctly. Also, the entire project, including all assets, must be placed in a folder created in your FTP root account on RenderStreet 

Uploading packed files

Packing a Blender project makes sure all external assets are included in the file. Depending on the kind of assets used in your project (external textures, linked libraries, fonts, video/image sequence textures), you may need to do one or all the steps below to complete the process.

1. In order to pack your textures, please use the menu command File -> External Data -> Pack into .blend file.


2. When using linked libraries, it's possible to pack them in the .blend file. Here's how to do it:
  • Make sure all linked libraries have the textures packed. If needed, pack them individually using the instructions from step 1
  • Use the "Pack Blender Libraries" command. This command is not present in the main menu, so you need to press spacebar (in Blender up to 2.79) or F3 (starting with Blender 2.80) and then search for it. 
  • For Blender 2.90 and newer, if the "Pack Blender Libraries" command does not appear in the F3 search box, do the following:
    • From the top of Blender select Edit -> Preferences.
    • From the list of tabs on the right, select Interface.
    • Now enable the option Developer Extras.
    • Save your preferences. Now you should be able to find the command you're looking for in the search operator.

3. Fonts are packed automatically with the command from step 1, in Blender versions after 2.72. 

If you are using an older version of Blender, you should note that fonts cannot be packed in the .blend files. This is a limitation of Blender. If you prefer to use packed files and use fonts, the only workaround for this is to convert the fonts to curves. Here's how to do it:

  • select the object
  • press alt-C on your keyboard
  • this brings up the contextual menu for converting the text
  • select "curves from mesh/text" or "mesh from text", both options should work. Choose one based on what suits you best, the mesh or curve object

After going through steps 1-3 you must save the file. 


4. Video textures, as well as image sequence textures do not get packed in the .blend file. If you use such textures, consider uploading the files unpacked instead. 


Also, PSD textures are not supported on Linux, so we recommend converting them to another format. All other image formats work as expected.

3rd party add-ons are supported on a case by case basis. Most add-ons work 'out of the box'. In case your project uses an add-on that doesn't work directly, please get in touch with us and let us know. Note that for add-ons that use scripting, scripts need to be enabled for your RenderStreet account.

When all data has been correctly packed, you can upload the file to our server.

Uploading unpacked files

In order to upload the files unpacked, please make sure you use relative paths in your file. Then follow these steps:

  1. Zip the .blend file and all the directories containing your data (textures and others)
  2. Upload the ZIP file either via the browser, FTP or cloud account and create your project
  3. Unzip the archive from our interface
  4. Launch the render from the resulted folder

Alternatively, upload the entire directory with the .blend file and the textures in a separate folder via FTP or via cloud upload. You'll then be able to select the folder in the FTP file list. 


IMPORTANT: Our systems are case-sensitive, so 'MyLibrary.blend' is not the same as 'mylibrary.blend'. Make sure your files (libraries, textures, video sequences, etc) are referenced with the exact names the files have, and the same letter case.


We also support more complex folder structures. Just make sure to use relative paths and upload your entire folder structure in a separate directory in the FTP root. You'll then be able to browse to the .blend file to render and the entire folder structure will be used when rendering. This can be used for more complex projects.

Have a special requirement that is not addressed above? Please get in touch and we'll help you.


    • Related Articles

    • How to Render a Blender file on RenderStreet

      On RenderStreet, a render is called a 'job'. The name applies to both still images and animations, and this article will show you how you can create jobs on our farm. In order to launch a job, you will need a positive credits balance (for on-demand ...
    • Texture baking in Blender

      Texture baking is supported on RenderStreet, via the BakeTool add-on developed by Cogumelo Softworks. We chose to support texture baking in this format since we believe that the BakeTool simplifies the process for you and makes it easier to organize ...
    • How baking works with Blender on RenderStreet

      In Blender, you can apply multiple physics attributes to objects. Some of them need baking in order to work. Please read below for the specific instructions for each type of baking and don't forget to read the important notes at the end of the ...
    • Using alembic caches in Blender

      When using Alembic files with Blender, please follow these steps to make sure they are set up correctly: 1. On your computer, copy the abc files in the same folder as the .blend file 2. In the blend file, locate each modifier that uses alembic and ...
    • Using MDD, PC2, VDB and Alembic cache files with Blender on RenderStreet

      MDD, PC2, VDB and ABC cache files are supported on RenderStreet. The easiest way to upload them to the farm is by using our Blender addon. The addon automatically collects these files and uploads them to our servers. If you do not wish to use the ...